Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Cannot get Insight Blockchain Explorer to Install

Discussion in 'Development Tech Discussion' started by ec1warc1, Jul 26, 2016.

  1. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    I have tried installing Insight for Dash on three versions of Linux: Centos 6, Ubuntu 16, Debian 7 - all 64 bit systems. I get lots and lots of different compile errors.... some go flying by during the install, and others kill the install process.

    So, where am I going wrong? Is there a particular Linux distro fit for this whereas others are not? (Please recommend one.) Must Insight be installed as root?

    What about Node.js? Is one version correct? There are two or three available.

    Also, reading HERE in this, I see that insight-api-dash is also required, but not mentioned on the install page. Which one first? insight-dash or insight-api-dash

    The install instruction page is far too lacking with details. Command #1, Command #2, startup and go! NOPE! That doesn't work, oh well! LOL! :eek: HELP!
     
  2. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    I am going to upload the errors, but I want to start at the correct place... 1. correct linux distro, 2. correct versions of packages, 3. correct users - etc.
     

    Attached Files:

  3. UdjinM6

    UdjinM6 Official Dash Dev
    Dash Core Team Moderator

    Joined:
    May 20, 2014
    Messages:
    3,631
    Likes Received:
    3,532
    Trophy Points:
    1,183
    • Like Like x 1
  4. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    I feel like a noob. How do you ping someone?
     
  5. snogcel

    snogcel Well-known Member
    Dash Core Team Foundation Member

    Joined:
    Jun 11, 2014
    Messages:
    189
    Likes Received:
    210
    Trophy Points:
    203
    @UdjinM6 already did :) Putting an "@" symbol before someone's name sends them a notification.

    First thing: depending on your use case/timing you might be advised to wait a little bit. The version of insight-api that you're setting up is based on a very old version of bitcore and we're working on setting up a new / shiny version that is much easier to install. Should have an official announcement later on this week :)

    With that disclaimer out of the way, the problem you're running in to I think could be one of the following:

    1. Compiling Dependencies
    2. Node version <--- I think this is the problem
    3. Python version

    In my experiences it's been either one or all of those items getting in the way.

    Here's what I'd suggest which should address item #1 and #2, from terminal (assuming a Ubuntu OS):

    sudo apt-get install build-essential
    curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.31.3/install.sh | bash
    nvm install v0.10.12

    at that point you should have a clean / compatible node version, try installing it again:

    npm install
    node insight.js

    I hope that helps! Future releases of insight are going to be TONS easier, can't wait to show you guys what we've been cooking up :)
     
    • Like Like x 2
  6. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    Thank you for your help. I really look forward to your announcement. I want to promote dash to Latin America, and a good blockchain browser is a start. So, the sooner, the better. :D

    Ok, now onto the technical stuff. I don't know why debian did not give my dash user a .bash_profile or .bashrc - perhaps that is part of the problem. That is now corrected. nvm install v0.10.12 complained about it.

    Nevertheless, we still have an error. :oops:

    [[email protected] insight-dash]$ npm install
    npm http GET https://registry.npmjs.org/grunt-angular-gettext
    npm http 200 https://registry.npmjs.org/grunt-angular-gettext
    npm ERR! Error: No compatible version found: [email protected]'^0.2.15'
    npm ERR! Valid install targets:
    npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.1.0","0.1.1","0.1.2","0.1.3","0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","0.2.6","0.2.7","0.2.8","0.2.9","0.2.11","0.2.12","0.2.13","0.2.14","0.2.15","2.0.0","2.0.1","2.1.0","2.1.3","2.1.9","2.1.10","2.1.11","2.1.12","2.1.13","2.1.14","2.1.15","2.2.0","2.2.1","2.2.2","2.2.3"]
    npm ERR! at installTargetsError (/home/dash/.nvm/v0.10.12/lib/node_modules/npm/lib/cache.js:719:10)
    npm ERR! at /home/dash/.nvm/v0.10.12/lib/node_modules/npm/lib/cache.js:641:10
    npm ERR! at saved (/home/dash/.nvm/v0.10.12/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
    npm ERR! at Object.oncomplete (fs.js:107:15)
    npm ERR! If you need help, you may report this log at:
    npm ERR! <http://github.com/isaacs/npm/issues>
    npm ERR! or email it to:
    npm ERR! <[email protected]>

    npm ERR! System Linux 3.2.0-4-amd64
    npm ERR! command "/home/dash/.nvm/v0.10.12/bin/node" "/home/dash/.nvm/v0.10.12/bin/npm" "install"
    npm ERR! cwd /home/dash/insight-dash
    npm ERR! node -v v0.10.12
    npm ERR! npm -v 1.2.32
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/dash/insight-dash/npm-debug.log
    npm ERR! not ok code 0
     
  7. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    Well, it has been a couple of days and I hate to be a quitter, but... I suppose I am just going to wait until the next big thing. I hope it is soon. Keep me posted.
     
  8. snogcel

    snogcel Well-known Member
    Dash Core Team Foundation Member

    Joined:
    Jun 11, 2014
    Messages:
    189
    Likes Received:
    210
    Trophy Points:
    203
    Hello, I was actually just on my way here to let you know that I'm going to have to take a closer look into this. It almost sounds like one of the dependencies on the old insight-api is deprecated. I found this online while searching for the error message: https://www.jfrog.com/jira/browse/RTFACT-9683.

    Error: No compatible version found: [email protected]'^0.2.15'

    I don't have a copy of this installed and likely won't have time to take a look until this weekend. I'd suggest perhaps googling that message to see if you can find any solutions, otherwise perhaps this is indeed a sign that it's best to wait for the new version :)

    Edit: this page might be useful - http://stackoverflow.com/questions/...ttext-not-found-error-when-using-angular-gett
     
  9. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    Thanks for the response. I hope the new version doesn't take long. I have very little time to work on fixing the old software. How do you expect to make the announcement? Here in the forum? I don't want to miss it. Thanks and best wishes!
     
  10. AndyDark

    AndyDark Well-known Member

    Joined:
    Sep 10, 2014
    Messages:
    347
    Likes Received:
    691
    Trophy Points:
    163
    Hey. should be a couple of days. You've come at a time when we're just at the end of upgrading everything to the new Insight plus X11 hash in Javascript for some integration projects / Evolution development and we're pretty busy all round. If you can wait a few days, we'll announce and the new version will be ready plus an official API launched.
     
  11. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    @snogcel @AndyDark Just thought I would revisit this thread and see if there is any news regarding the new version of insight. I will start working on my server again after August 20. I have some traveling to do right now. First going to USA, then to Paraguay! So excited about Paraguay! Anyway, after that... I will get to work on this again. So, please keep me posted and thanks!!!!
     
  12. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    @snogcel @AndyDark How is this insight explorer coming along? I remember somewhere seeing that you were nearly done, compile on the server and you can use it now (somewhere). Now that my masternode project is completed, I would like to try installing your new version of insight. Thank you!
     
  13. snogcel

    snogcel Well-known Member
    Dash Core Team Foundation Member

    Joined:
    Jun 11, 2014
    Messages:
    189
    Likes Received:
    210
    Trophy Points:
    203
    hey @ec1warc1 we're getting close, I plan to wait for the next phase of testnet to get started then make this available. We'll keep you posted :)
     
    • Like Like x 1
  14. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    I am ready when you are. Thanks!
     
  15. nmarley

    nmarley Administrator
    Dash Core Team Moderator

    Joined:
    Jun 28, 2014
    Messages:
    349
    Likes Received:
    418
    Trophy Points:
    133
    Dash Address:
    XsUFct27gKMRZ7JFxoxcMgjaBDXndk5kXT
    @ec1warc1 : Are you just wanting to run a version Insight for Dash? I'm running a version now which is working fine on Ubuntu. Commit hash fc232ff, but I don't know if that helps you or not.
     
  16. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    @mmarley I am waiting for a new version that is supposed to be available very soon. @snogcel @AndyDark should be releasing it shortly. Any news guys?
     
  17. snogcel

    snogcel Well-known Member
    Dash Core Team Foundation Member

    Joined:
    Jun 11, 2014
    Messages:
    189
    Likes Received:
    210
    Trophy Points:
    203
    Hey @ec1warc1 should be soon :) I'm waiting for some work on testnet / 12.1 to be completed in order to ensure that we have stable/good binaries to distribute with it. If you're in a rush you might want to check out the old version, but if you can wait a bit longer you'll have the latest/greatest.
     
  18. darkzero

    darkzero Member

    Joined:
    Jun 6, 2014
    Messages:
    44
    Likes Received:
    35
    Trophy Points:
    58
    @snogcel bumping this thread coz i'm interested too, any news?
     
  19. snogcel

    snogcel Well-known Member
    Dash Core Team Foundation Member

    Joined:
    Jun 11, 2014
    Messages:
    189
    Likes Received:
    210
    Trophy Points:
    203
  20. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    169
    Trophy Points:
    113
    Fortunately, I am keeping myself busy with a different part of my new website involving dash, so I don't even have time right now to install the new insight. But, I am definitely still interested. Keep me posted.
     

Share This Page