• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

Masternode on Odroid C2


New member
Masternode Owner/Operator
Hello, this is my first post but I've been a masternode operator for almost two years now.
I had it running on a Raspberry Pi 2 Model B which I set up following the guide for that model.

The thing is now MNs need more RAM and storage space to run and so I bought an Odroid C2 with 2GB RAM and a 64GB class 10 MicroSD and installed armbian on it (which is 64bit).
I tried running the Raspberry Pi 2 wallet version downloaded from the official site (dashcore-, because that would be compiled for an ARM system, but when I run dashd I get No such file or directory.

Tried with dashcore- too but it is clearly not compiled for ARM as I get cannot execute binary file: Exec format error.

So, I tried to compile it myself as I did with every new Dash version on my Raspberry Pi, and now I'm stuck with a problem:
when make gets to the file libbitcoin_server_a-init.o gets stuck forever and never progresses.
I assumed it was a memory shortage problem and checked how RAM was doing. Effectively, process cc1plus used all my RAM (1759028 KiB) and also noticed only 1 of the 4 processors was being used.

I started to try different SWAP configurations, created a 512MB swap file, then tried with a 2GB one, and also with a smaller one of 128MB, but nothing works, the process consumes all the RAM, then starts to use SWAP really slowly (swap usage increases but very slowly) and that's when kswapd0 process takes 100%CPU usage and nothing more happens. It doesn't hang, but never ends (I gave it more than 4 hours of grace).

Can you lend me a hand here? If we can work this out we'd have a new "Masternodes can be run on Odroid C2" title to show everywhere and that can't harm Dash ;)

I think of two or three possible ways of facing this problems:
1) configure correctly my Odroid C2 so the swap can do it's job and finally compile.
2) compile the ARM version of Dash on another computer (is that possible? read something about multi-arch compilation somewhere) and send it to my Odroid C2.
3) if it's the case, get any missing libraries so dashcore- version can run on my Odroid (perhaps this is the simplest solution and I just can't run it because I'm missing something).

Any help is much appreciated. Thank you!!