New CoPay Beta for Android landed today...

t0dd

Active Member
Mar 21, 2016
150
132
103
keybase.io
Dash Address
XyxQq4qgp9B53QWQgSqSxJb4xddhzk5Zhh
Reference previous testing: https://www.dash.org/forum/threads/...roid-8-1-0-on-pixel-xl-log.39110/#post-191402

Results of a 5 minute of testing, more to come when I have time...

  • Bug, maybe: created new wallet. It created two with the same name.
    I say maybe because I wonder if Lastpass constantly offering to search for a password during the password dialogue is somehow triggering this error. But happens every time (personal wallet tested only).
  • Bug: If you create a wallet without an encryption password the wallet gets marked as "backup needed", which is incorrect. The password is not a backup, it's an encryption password. The seed is the backup. See next bullet.
  • Dangerous usability issue: The app still doesn't kick you into the backup screens upon new wallet creation (each wallet has a different seed). I have previously mentioned my concerns over this. An easier option may be that if a user creates a new wallet, it doesn't force you through the backup screens, but instead displays the red "backup needed" mentioned previously and the user will then be reminded to search for the backup wizard-like workflow in order to remove that red reminder. I.e., "backup needed" would then become correctly associated to a need for the user to write down the seed rather than the current incorrect behavior where it gets displayed if you haven't encrypted the wallet.
Thanks! I hope to do more testing soon. -t
 
Last edited:
  • Like
Reactions: tungfa

Liz R

New Member
Mar 2, 2018
30
117
33
Reference previous testing: https://www.dash.org/forum/threads/...roid-8-1-0-on-pixel-xl-log.39110/#post-191402

Results of a 5 minute of testing, more to come when I have time...

  • Bug, maybe: created new wallet. It created two with the same name.
    I say maybe because I wonder if Lastpass constantly offering to search for a password during the password dialogue is somehow triggering this error. But happens every time (personal wallet tested only).
  • Bug: If you create a wallet without an encryption password the wallet gets marked as "backup needed", which is incorrect. The password is not a backup, it's an encryption password. The seed is the backup. See next bullet.
  • Dangerous usability issue: The app still doesn't kick you into the backup screens upon new wallet creation (each wallet has a different seed). I have previously mentioned my concerns over this. An easier option may be that if a user creates a new wallet, it doesn't force you through the backup screens, but instead displays the red "backup needed" mentioned previously and the user will then be reminded to search for the backup wizard-like workflow in order to remove that red reminder. I.e., "backup needed" would then become correctly associated to a need for the user to write down the seed rather than the current incorrect behavior where it gets displayed if you haven't encrypted the wallet.
Thanks! I hope to do more testing soon. -t
Thanks so much for reporting these - will look into them. Appreciate your help in testing. :)