Masternode 10.15.13 update problem

S_Uber

New Member
Jun 13, 2014
15
2
3
South Africa
Greetings,

I am having issues updating my masternode. I downloaded 0.10.15.13 but when I run darkcoind it says "Error: cannot obtain lock on data directory /home/ubuntu/.darkcoin. Darkcoin is probably already running."

But if I use darkcoind stop, it says "error, couldn't connect to server".

I managed to get through all the previous updates so not sure what I did wrong, but I think I stuffed it up :(

Can anyone please advise?
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
Code:
ps aux | grep 'darkcoind'
Get the pid of the process, then

Code:
kill -9 <pid>
This will kill the running process. Nevertheless it seems your darkcoin.conf contains wrong data for rpcport/rpcuser/rpcpassword so that the client is not able to connect. Check these settings first.
 

S_Uber

New Member
Jun 13, 2014
15
2
3
South Africa
OK I killed it by pid. Now when I try "darkcoind" it says it can't connect to server.

Here's my darkcoin.conf. Anything look suspicious?

rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
addnode=23.23.186.131
#--------------------
externalip=<ec2-external-ip>

Thanks so much for the assistance!
 

UdjinM6

Official Dash Dev
Dash Core Team
Moderator
May 20, 2014
3,637
3,536
1,183
OK I killed it by pid. Now when I try "darkcoind" it says it can't connect to server.

Here's my darkcoin.conf. Anything look suspicious?

rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
addnode=23.23.186.131
#--------------------
externalip=<ec2-external-ip>

Thanks so much for the assistance!
you need two more lines
Code:
rpcuser=darkcoinrpc
rpcpassword=superSecretPassword
 
  • Like
Reactions: flare

S_Uber

New Member
Jun 13, 2014
15
2
3
South Africa
Oh yeah, I have those but forgot to include.

When I log on it says /dev/xvda1 needs to be checked. I'm going to restart the server and check what happens.
 

S_Uber

New Member
Jun 13, 2014
15
2
3
South Africa
OK I figured it out. In the "Masternode guide for complete noobs", after the "wget" and "tar xfvz darkcoin" steps, another step is found that is not in other guides (as far as I can tell).

He does "cp darkcoin-0.10.1x.xx-linux/bin/64/darkcoind darkcoind" which I gather is some sort of symbolic link or something?

I'm just winging it so I'm surprised it's worked thus far. But always looking for a chance to further my understanding. Thanks again flare and UdjinM6 for your assistance. Very much appreciated.
 

UdjinM6

Official Dash Dev
Dash Core Team
Moderator
May 20, 2014
3,637
3,536
1,183
OK I figured it out. In the "Masternode guide for complete noobs", after the "wget" and "tar xfvz darkcoin" steps, another step is found that is not in other guides (as far as I can tell).

He does "cp darkcoin-0.10.1x.xx-linux/bin/64/darkcoind darkcoind" which I gather is some sort of symbolic link or something?

I'm just winging it so I'm surprised it's worked thus far. But always looking for a chance to further my understanding. Thanks again flare and UdjinM6 for your assistance. Very much appreciated.
Nope, no linking here. It just a "make a copy" command, syntax is "cp <from> <to>"
and in this case if you copy it to your home directory and not in /usr/bin/ you have to issue commands with "./darkcoind" (or "~/darkcoind" if you run it not in your home directory) and not with "darkcoind"