How to set up ec2 t1.micro Ubuntu for Masternode part 2/3

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
I don't know... I followed this tutorial line by line... :mad:
I'll start again from Part 2... maybe I missed a step... But I'm sure I didn't.

EDIT: ok.. so I did apt-get update and apt-get dist-upgrade again, just to be sure... I am 150% I did it the first time. If everything is updated and upgraded, why the heck did it do it again?

Ok, progress until step 8 (Reboot) - does this look ok?



Now, on Step 8, should I copy/paste current, or get RC2 !?

EDIT: seriously, sorry about the spam, but i did take the bloody day off for this and I'm extremely frustrated... I went ahead and substituted "beta" with "rc2" in the links for the more updated daemon. But its the exact same thing. here is the config

Code:
  GNU nano 2.2.6                          File: /home/ubuntu/.darkcoin/darkcoin.conf                                                           

#----
rpcuser=not_my_real_login
rpcpassword=stupid_password_123
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
#--------------------
# change ami_public_ip to public ip address which you connected by ssh
externalip=54.72.246.62
#---------------------
#------------
masternode=1
addnode=23.23.186.131
#----------
but when I try to run darkcoind, it says

Code:
[email protected]:~$ darkcoind
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Aborted (core dumped)
 
Last edited by a moderator:

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
I terminated the instance and tried again, except this time i stayed as root for everything (wget rc2 etc) and bingo, everything worked.
I have no clue why, but I'm running the MN ;)
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
RC2 is ONLY in testnet right now, you can't use it live. It probably won't go live either, not until RC3
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
Code:
git clone https://github.com/evan82/darkcoin.git
should be
Code:
git clone https://github.com/darkcoinproject/darkcoin.git
now
 

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
I've got to step 11.

When I run darkcoind I get, "Darkcoin server starting" and it does nothing else.

ssh-ing in from another terminal I run darkcoind getinfo/getmininginfo and get this:
Code:
[email protected]:~$ darkcoind getinfo
{
  "version" : 90102,
  "protocolversion" : 70002,
  "walletversion" : 60000,
  "balance" : 0.00000000,
  "blocks" : 38646,
  "timeoffset" : 0,
  "connections" : 9,
  "proxy" : "",
  "difficulty" : 442.61713803,
  "testnet" : false,
  "keypoololdest" : 1398697015,
  "keypoolsize" : 101,
  "paytxfee" : 0.00000000,
  "mininput" : 0.00001000,
  "errors" : ""
}
Code:
[email protected]:~$ darkcoind getmininginfo
{
  "blocks" : 44127,
  "currentblocksize" : 0,
  "currentblocktx" : 0,
  "difficulty" : 541.28419999,
  "errors" : "",
  "generate" : false,
  "genproclimit" : -1,
  "hashespersec" : 0,
  "networkhashps" : 13059014921,
  "pooledtx" : 0,
  "testnet" : false
}
log gives a bunch of stuff like:
Code:
2014-05-06 10:05:21 connected 192.99.32.166:9999
2014-05-06 10:05:21 send version message: version 70002, blocks=0, us=54.187.147.18:9999, them=192.99.32.166:9999, peer=192.99.32.166:9999
2014-05-06 10:05:21 socket closed
2014-05-06 10:05:21 disconnecting node 192.99.32.166:9999
2014-05-06 10:05:24 trying connection 192.99.32.166:9999 lastseen=108.1hrs
2014-05-06 10:05:24 connected 192.99.32.166:9999
2014-05-06 10:05:24 send version message: version 70002, blocks=0, us=54.187.147.18:9999, them=192.99.32.166:9999, peer=192.99.32.166:9999
2014-05-06 10:05:24 socket closed
2014-05-06 10:05:24 disconnecting node 192.99.32.166:9999
2014-05-06 10:05:27 trying connection 162.252.83.44:9999 lastseen=101.3hrs
Is this looking right so far?

I'm worried I have the wrong version of darkcoind

edit: looks up to date now with what my wallet and miner are showing me:
Code:
[email protected]:~$ darkcoind getmininginfo
{
  "blocks" : 63750,
  "currentblocksize" : 0,
  "currentblocktx" : 0,
  "difficulty" : 861.16409190,
  "errors" : "",
  "generate" : false,
  "genproclimit" : -1,
  "hashespersec" : 0,
  "networkhashps" : 29468337134,
  "pooledtx" : 12,
  "testnet" : false
}
log now showing stuff like:
Code:
[email protected]:~$ tail -f ~/.darkcoin/debug.log
2014-05-06 10:18:54 Added 1 addresses from 192.99.32.166: 8 tried, 9081 new
2014-05-06 10:18:57 Added 1 addresses from 58.174.3.159: 8 tried, 9081 new
2014-05-06 10:19:11 Added 1 addresses from 162.243.44.147: 8 tried, 9082 new
2014-05-06 10:19:19 ThreadRPCServer method=getmininginfo
2014-05-06 10:19:35 socket send error 104
2014-05-06 10:19:35 disconnecting node 122.238.109.207:55674
2014-05-06 10:19:36 Added 1 addresses from 209.208.110.92: 8 tried, 9082 new
2014-05-06 10:19:37 Added 1 addresses from 162.243.44.147: 8 tried, 9083 new
2014-05-06 10:20:02 Added 1 addresses from 123.5.90.214: 8 tried, 9082 new
2014-05-06 10:20:03 Added 1 addresses from 209.208.110.92: 8 tried, 9082 new
2014-05-06 10:20:17 Added 1 addresses from 123.5.90.214: 8 tried, 9083 new
2014-05-06 10:20:26 accepted connection 122.238.109.207:49307
2014-05-06 10:20:26 send version message: version 70002, blocks=63750, us=54.187.147.18:9999, them=122.238.109.207:49307, peer=122.238.109.207:49307
2014-05-06 10:20:26 receive version message: /Satoshi:0.9.2.2/: version 70014, blocks=42265, us=54.187.147.18:9999, them=[2001:0:9d38:90d7:38fd:3967:8511:9230]:9999, peer=122.238.109.207:49307
2014-05-06 10:20:29 Added 1 addresses from 162.243.44.147: 8 tried, 9083 new
Sorry to be a big girls blouse about it all, want to get it right! :)
 
Last edited by a moderator:

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
UPDATED with some answers to my own questions, hopefully they are correct!

OK I forged ahead regardless, I am now stuck at step 18

darkcoind masternode start mypassphrase gives me "incorrect passphrase"

I entered mypassphrase as the one I put in darkcoin.conf, couldn't remember setting one anywhere else, but no worky.

edit: OK you're supposed to enter the passphrase of your wallet.dat !!! Told you I was senile.
Code:
successfully started masternode
How can I see it from elsewhere? IP is 54.187.147.18
"darkcoind masternode list"

And can I close that terminal window? Because the passphrase to my 1000DRK is now sat there in plain sight.
Yes, daemon will persist

This works on linux:

darkcoind masternode start `head -1`

Type your password on the next line. If you do it this way the history will show 'head -1' instead of your password.
 
Last edited by a moderator:

bbbbbb2014

New Member
May 8, 2014
1
0
1
Hi there chaeplin!

For some reason, I am unable to pull the darkcoin client from github, as the password is required for download. I took a look and it seemed to me, the git archive is public. So, what to do?

Code:
[email protected]:~# git clone https://github.com/evan82/darkcoin.git
Cloning into 'darkcoin'...
Username for 'https://github.com':
Password for 'https://github.com':
fatal: Authentication failed
 

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
Hi there chaeplin!

For some reason, I am unable to pull the darkcoin client from github, as the password is required for download. I took a look and it seemed to me, the git archive is public. So, what to do?

Code:
[email protected]:~# git clone https://github.com/evan82/darkcoin.git
Cloning into 'darkcoin'...
Username for 'https://github.com':
Password for 'https://github.com':
fatal: Authentication failed

git clone https://github.com/darkcoinproject/darkcoin.git

I have edited step 9.
 

Rux

Member
Mar 9, 2014
69
32
58
Stuck on #16

-bash: ./darkcoind: cannot execute binary file: Exec format error

i stoped darkcoind, and put new wallet.dat, after that i went to start ./darkcoind and got this error :)

can chaeplin help? or anyone :)

edit: ok i think pass that error
but new one when typing masternode start without pass, i didnt put password on dat because im testing 1st.
error: {"code":-1,"message":"masternode list|count|current> passphrase\n"}
this can be fixed when i put .dat with pass

next thing is when i type darkcoind getinfo i think something is blocking me to sync cache
"version" : 90202,
"protocolversion" : 70014,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 45993,
"timeoffset" : 0,
"connections" : 12,
"proxy" : "",
"difficulty" : 349.22897585,
"testnet" : false,
"keypoololdest" : 1399634753,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
 
Last edited by a moderator:

Comrade Capitalist

New Member
May 9, 2014
1
0
1
Hello everyone.
I've successfully started masternode on one of my local machines using this guide. The only problem is that after I restarted darkcoind my IP is listed twice in 'masternode list'.
How can I delete the double entry?
And maybe someone has security tips for running node on local machine behind router (I had to open port 9999 in the router through port forwarding, UPnP is disabled).
 

fernando

Powered by Dash
Foundation Member
May 9, 2014
1,527
2,059
283
I made this work a few days ago, but now I'm doing it again with RC2 and I get an error in #6.

When I write the code under '* enable sysstat(edit)' it does nothing and I have to interrupt.

If I do it line by line, after entering:
Code:
edit /etc/default/sysstat
I get:
Warning: unknown mime-type for "/etc/default/sysstat" -- using "application/octet-stream"
Error: no "edit" mailcap rules found for type "application/octet-stream"
Any ideas where I'm doing it wrong?
 

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
I made this work a few days ago, but now I'm doing it again with RC2 and I get an error in #6.

When I write the code under '* enable sysstat(edit)' it does nothing and I have to interrupt.

If I do it line by line, after entering:
Code:
edit /etc/default/sysstat
I get:


Any ideas where I'm doing it wrong?
Use vi or nano.
edit means 'do edit' :)
 
  • Like
Reactions: fernando

snguyen

New Member
May 10, 2014
15
0
1
I got the following error when running in masternode locally (I've connected to remote daemon successfully)

Code:
[email protected]:~/DRK/beta$ ./darkcoind masternode start "my-pass-phrase"
not capable masternode

[email protected]:~/DRK/beta$ ./darkcoind getbalance
1000.00000000
Do you know what is the reason?

I have managed to run it successfully. I forgot that on testnet the port is 19999, not 9999 as in real net. :)
 
Last edited by a moderator:

rickraw

New Member
Mar 28, 2014
7
1
3
Ok, I am having troubles getting a connection:

I am using other VPS (not AWS) so haven't played with the iptables yet. Opened port 9999 though.

Any thoughts?

Code:
:~# tail -f ~/.darkcoin/debug.log
2014-05-16 18:47:19 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:19 connect() failed after select(): Connection refused
2014-05-16 18:47:19 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:19 connect() failed after select(): Connection refused
2014-05-16 18:47:20 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:20 connect() failed after select(): Connection refused
2014-05-16 18:47:20 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:20 connect() failed after select(): Connection refused
2014-05-16 18:47:21 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:21 connect() failed after select(): Connection refused
2014-05-16 18:47:21 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:21 connect() failed after select(): Connection refused
2014-05-16 18:47:22 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:22 connect() failed after select(): Connection refused
2014-05-16 18:47:22 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:22 connect() failed after select(): Connection refused
Code:
:~# darkcoind getmininginfo
{
    "blocks" : 0,
    "currentblocksize" : 0,
    "currentblocktx" : 0,
    "difficulty" : 0.00024414,
    "errors" : "",
    "generate" : false,
    "genproclimit" : -1,
    "hashespersec" : 0,
    "networkhashps" : 0,
    "pooledtx" : 0,
    "testnet" : false
}
Code:
:~# darkcoind getinfo
{
    "version" : 90304,
    "protocolversion" : 70014,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 0,
    "timeoffset" : 0,
    "connections" : 0,
    "proxy" : "",
    "difficulty" : 0.00024414,
    "testnet" : false,
    "keypoololdest" : 1400264951,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "errors" : ""
}
 

Lzeppelin

Member
Feb 27, 2014
283
57
88
Ok, I am having troubles getting a connection:

I am using other VPS (not AWS) so haven't played with the iptables yet. Opened port 9999 though.

Any thoughts?

Code:
:~# tail -f ~/.darkcoin/debug.log
2014-05-16 18:47:19 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:19 connect() failed after select(): Connection refused
2014-05-16 18:47:19 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:19 connect() failed after select(): Connection refused
2014-05-16 18:47:20 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:20 connect() failed after select(): Connection refused
2014-05-16 18:47:20 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:20 connect() failed after select(): Connection refused
2014-05-16 18:47:21 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:21 connect() failed after select(): Connection refused
2014-05-16 18:47:21 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:21 connect() failed after select(): Connection refused
2014-05-16 18:47:22 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:22 connect() failed after select(): Connection refused
2014-05-16 18:47:22 trying connection 192.99.32.166:9999 lastseen=85.5hrs
2014-05-16 18:47:22 connect() failed after select(): Connection refused
Code:
:~# darkcoind getmininginfo
{
    "blocks" : 0,
    "currentblocksize" : 0,
    "currentblocktx" : 0,
    "difficulty" : 0.00024414,
    "errors" : "",
    "generate" : false,
    "genproclimit" : -1,
    "hashespersec" : 0,
    "networkhashps" : 0,
    "pooledtx" : 0,
    "testnet" : false
}
Code:
:~# darkcoind getinfo
{
    "version" : 90304,
    "protocolversion" : 70014,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 0,
    "timeoffset" : 0,
    "connections" : 0,
    "proxy" : "",
    "difficulty" : 0.00024414,
    "testnet" : false,
    "keypoololdest" : 1400264951,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "errors" : ""
}
Exact same thing happened to me, was about to post here last night then it started syncing. How long have you been waiting? Try waiting at least an hour, it should start syncing/connecting soon.
 

rickraw

New Member
Mar 28, 2014
7
1
3
Exact same thing happened to me, was about to post here last night then it started syncing. How long have you been waiting? Try waiting at least an hour, it should start syncing/connecting soon.
I can wait awhile just concerned because it is saying connection refused...
 

rickraw

New Member
Mar 28, 2014
7
1
3
Still nothing. Can I close all instances of port 53, 953, and 123 (DNS and NTP)?

Code:
:~# tail -f ~/.darkcoin/debug.log
2014-05-16 20:01:08 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:08 connect() failed after select(): Connection refused
2014-05-16 20:01:09 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:09 connect() failed after select(): Connection refused
2014-05-16 20:01:09 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:09 connect() failed after select(): Connection refused
2014-05-16 20:01:10 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:10 connect() failed after select(): Connection refused
2014-05-16 20:01:10 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:10 connect() failed after select(): Connection refused
2014-05-16 20:01:11 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:11 connect() failed after select(): Connection refused
2014-05-16 20:01:11 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:11 connect() failed after select(): Connection refused
2014-05-16 20:01:12 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:12 connect() failed after select(): Connection refused
^C

[email protected]:~# sudo netstat -lnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:9999            0.0.0.0:*               LISTEN      816/darkcoind  
tcp        0      0 <MY IP>:53       0.0.0.0:*               LISTEN      426/named      
tcp        0      0 127.0.0.2:53            0.0.0.0:*               LISTEN      426/named      
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      426/named      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      376/sshd       
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      426/named      
tcp6       0      0 :::9998                 :::*                    LISTEN      816/darkcoind  
tcp6       0      0 :::9999                 :::*                    LISTEN      816/darkcoind  
tcp6       0      0 :::53                   :::*                    LISTEN      426/named      
tcp6       0      0 :::22                   :::*                    LISTEN      376/sshd       
tcp6       0      0 ::1:953                 :::*                    LISTEN      426/named      
udp        0      0 <MY IP>:53       0.0.0.0:*                           426/named      
udp        0      0 127.0.0.2:53            0.0.0.0:*                           426/named      
udp        0      0 127.0.0.1:53            0.0.0.0:*                           426/named      
udp        0      0 <MY IP>:123      0.0.0.0:*                           467/ntpd       
udp        0      0 127.0.0.2:123           0.0.0.0:*                           467/ntpd       
udp        0      0 127.0.0.1:123           0.0.0.0:*                           467/ntpd       
udp        0      0 0.0.0.0:123             0.0.0.0:*                           467/ntpd       
udp6       0      0 :::53                   :::*                                426/named      
udp6       0      0 ::1:123                 :::*                                467/ntpd       
udp6       0      0 <MY IPV6 IP>:::123 :::*                                467/ntpd       
udp6       0      0 :::123                  :::*                                467/ntpd
 

Lzeppelin

Member
Feb 27, 2014
283
57
88
Still nothing. Can I close all instances of port 53, 953, and 123 (DNS and NTP)?

Code:
:~# tail -f ~/.darkcoin/debug.log
2014-05-16 20:01:08 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:08 connect() failed after select(): Connection refused
2014-05-16 20:01:09 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:09 connect() failed after select(): Connection refused
2014-05-16 20:01:09 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:09 connect() failed after select(): Connection refused
2014-05-16 20:01:10 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:10 connect() failed after select(): Connection refused
2014-05-16 20:01:10 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:10 connect() failed after select(): Connection refused
2014-05-16 20:01:11 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:11 connect() failed after select(): Connection refused
2014-05-16 20:01:11 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:11 connect() failed after select(): Connection refused
2014-05-16 20:01:12 trying connection 192.99.32.166:9999 lastseen=86.7hrs
2014-05-16 20:01:12 connect() failed after select(): Connection refused
^C

[email protected]:~# sudo netstat -lnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:9999            0.0.0.0:*               LISTEN      816/darkcoind 
tcp        0      0 <MY IP>:53       0.0.0.0:*               LISTEN      426/named     
tcp        0      0 127.0.0.2:53            0.0.0.0:*               LISTEN      426/named     
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      426/named     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      376/sshd      
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      426/named     
tcp6       0      0 :::9998                 :::*                    LISTEN      816/darkcoind 
tcp6       0      0 :::9999                 :::*                    LISTEN      816/darkcoind 
tcp6       0      0 :::53                   :::*                    LISTEN      426/named     
tcp6       0      0 :::22                   :::*                    LISTEN      376/sshd      
tcp6       0      0 ::1:953                 :::*                    LISTEN      426/named     
udp        0      0 <MY IP>:53       0.0.0.0:*                           426/named     
udp        0      0 127.0.0.2:53            0.0.0.0:*                           426/named     
udp        0      0 127.0.0.1:53            0.0.0.0:*                           426/named     
udp        0      0 <MY IP>:123      0.0.0.0:*                           467/ntpd      
udp        0      0 127.0.0.2:123           0.0.0.0:*                           467/ntpd      
udp        0      0 127.0.0.1:123           0.0.0.0:*                           467/ntpd      
udp        0      0 0.0.0.0:123             0.0.0.0:*                           467/ntpd      
udp6       0      0 :::53                   :::*                                426/named     
udp6       0      0 ::1:123                 :::*                                467/ntpd      
udp6       0      0 <MY IPV6 IP>:::123 :::*                                467/ntpd      
udp6       0      0 :::123                  :::*                                467/ntpd
I'd assume so, sorry I'm no guru I just saw that error before and thought waiting would help.
 

eltito

Active Member
Apr 21, 2014
157
185
103
Does this look about right for non-Amazon EC2 iptable settings?

Code:
-P INPUT DROP
-P OUTPUT DROP
-P FORWARD DROP
-A INPUT -i lo -j ACCEPT
-A INPUT -p tcp --dport 22 -j ACCEPT
-A INPUT -p tcp --dport 9999 -j ACCEPT
-A OUTPUT -p tcp --dport 9999 -j ACCEPT
-A INPUT -j DROP
-A OUTPUT -j DROP
I'm going to tailor it to only allow ssh from a couple IP addresses, but am I on the right track at least?
 

rickraw

New Member
Mar 28, 2014
7
1
3
Well I am up using this guide! Thanks alot.

I would like to go the cold storage route but couldn't figure it out with my windows wallet. Assuming my wallet.dat isn't compromised on the masternode, can I still use my local windows wallet (where the backup wallet.dat came from) for in/out transactions as long as there are always >1000 DRK in it?
 

jimbit

Well-known Member
Foundation Member
May 23, 2014
229
103
203
awsome setup guide... Thank you. will send coin.

question: How do the masternodes get paid.. does it go to the address of the 1k drk?
 

Bizmonger

New Member
Jun 2, 2014
28
4
3
Step #1
1. login to ec2 ami
Code:
ssh -i downloaded_pemfile [EMAIL][email protected]mi_public_ip
[/EMAIL]
I cannot not get past the first step.
I can login the system. However, the following command does not work for me:
ssh -i "C:\SSH_KEY_FOR_EC2_SP.pem" [email protected]my_path.amazonaws.com

I receive an error saying that no file or directory is found.

What pem file should I use then?
 
Last edited by a moderator:

derk

New Member
Jun 4, 2014
37
20
8
don't suppose there's any hope of someone putting together a wizard for this?
 

Bizmonger

New Member
Jun 2, 2014
28
4
3
Step #1
Did you set up a private key and downloaded it somewhere? This is your file!
All I know is that I provided some pem file and had to browse to it when I configured the an instance on the AWS EC2 VM.
That's the same pem file that I am trying to specify again.

I ended up skipping step #1 and got to step #6 where I apparently do not have permission.
I'm not sure if step #1 was necessary.
 
Last edited by a moderator:

Bizmonger

New Member
Jun 2, 2014
28
4
3
Step #6
I also receive an error:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

When I try to login as root, I get kicked out the system.

Any suggestions?
 
Last edited by a moderator:

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
All I know is that I provided some pem file and had to browse to it when I configured the an instance on the AWS EC2 VM.
That's the same pem file that I am trying to specify again.

I ended up skipping step #1 and got to step #6 where I apparently do not have pernission.
I'm not sure if step #1 was necessary.
Terminate your instance and set up a new one. Create and download a new key and use this. Try again.