Error 28 and /dashman_functions.sh: line 1238: : command not found

bou

New Member
Mar 26, 2016
27
7
3
Hi,
I just update my MN after a POSE ban (I don't know if it's related)

I use Dashman tu make the update, but at the end of the update I was stuck with "waiting for dashd to respond ....................................."
So I make a reboot, but now I'm stuck with some kind of sentinel error I guess?
Main error is:

/dashman_functions.sh: line 1238: : command not found

here is my dashman status report:


~/dashman/dashman status
dashman version 0.1.28 (7-gd706581) - Mon Feb 3 09:46:55 UTC 2020
gathering info, please wait... error code: -28
error message:
Loading block index...
DONE!

hostname : xxxxxxxxxxxxxxx
host uptime/load average : 0 days, 0.73 0.20 0.07
dashd bind ip address : xxxxxxxxxx
dashd version : 0.14.0.5
dashd up-to-date : YES
dashd running : YES
dashd uptime : 0 days, 0 hours, 00 mins, 42 secs
dashd responding (rpc) : YES
dashd listening (ip) : YES
dashd connecting (peers) : YES
dashd port open : YES
dashd connection count : 1
dashd blocks synced : NO
last block (local dashd) : 0
(chainz) : 1215245
(dash.org) : 1215246
(dashwhale) : 1215246
(masternode.me) : 1215246 - no forks detected
dashd current difficulty :
masternode registered : NO
masternode visible (local) : NO
masternode visible (ninja) : NO
masternode address : xxxxxxxxxxxxxxxxxxxx
masternode funding txn : xxxxxxxxxxxxxxxxxxxxxxxx
masternode queue/count : 0/1
masternode mnsync state : /home/bababa/dashman/lib/dashman_functions.sh: line 1238: : command not found
masternode network state :
masternode last payment : xxxxxxxxxxxxxx
masternode balance : 1009
sentinel installed : YES
sentinel tests passed : NO
sentinel crontab enabled : YES
sentinel online : NO - sync incomplete
Exiting.



Of course it does no change15 minutes later. I think it's not a Sync delay issue because of the error message, and the fact that the block numbers are green.
The Local Dahs last block is "0" witch is odd too.
Any help would be appreciate.
 

bou

New Member
Mar 26, 2016
27
7
3
After one hour things seems to have been solved (I tryed various things in the meantime, so I don't know if it was just a Sync delay issue or not)

I try to test my "sentinel" because of the POSE ban, the best way to do it is to dash.cli stop and wait to see if it restart?
 

qwizzie

Well-known Member
Aug 6, 2014
1,609
764
183
After one hour things seems to have been solved (I tryed various things in the meantime, so I don't know if it was just a Sync delay issue or not)

I try to test my "sentinel" because of the POSE ban, the best way to do it is to dash.cli stop and wait to see if it restart?
If you have a restart script running through Dash Central then you can indeed test it by stopping your dashd through ./dash-cli stop and see in Dash Central if it gets restarted after 10 minutes.
You will find it in section 'Incidents' and it will look like this : 'DASH daemon has been restarted due to unresponsiveness for more than 10 minutes!'

I highly recommend using Dash Central optional auto restart script, you can find more information about it here : https://www.dashcentral.org --> My Account --> Remote Data Monitoring and Autorestart (optional)

Be informed that masternode operators need to do more then just update their masternodes after a PoSe ban, they need to create a ProUpServTx to get out of a PoSe ban --> https://docs.dash.org/en/stable/masternodes/maintenance.html#proof-of-service-bans
 
Last edited: