delete

humanitee

New Member
Mar 30, 2014
13
4
3
It's a firewall issue most likely. Did you set your security permissions correctly on Amazon? Port 0 is used when 9999 is blocked, at least it appears that way. It's the process requesting a port to use from the OS. Go to EC2 management -> Network and Security -> Security Groups -> Inbound and see if you have TCP 9999 open.
 

humanitee

New Member
Mar 30, 2014
13
4
3
Ok here is my new theory. Do you have TCP 9999 enabled on your home machine with your local firewall/router configured? If the local machine is registering the remote master node's port with the port it communicated on, then perhaps it is using 0 if 9999 is blocked, thus registering 0.
 

humanitee

New Member
Mar 30, 2014
13
4
3
Do I have to open port 9999 on my local server? That would mean on my home-router I should open port 9999 for incoming traffic? I did not do that, you are correct with this.
Correct. Try opening that and seeing if it works, I bet it does!

I thought only the remote machine needs port 9999 open
Port 0 would probably still work. I just want to verify this is why 0 is appearing.
 
Last edited by a moderator:

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
firewall should be OK, i removed firewall filters and i checked the port with netcat (and also with nmap). its open from outside. I also followed chaeplins guide very carefully and I know what I am doing.

edit: only thing I did not fully understand is "elastic ip", but I activated it and it shows the same ip than the "public ip" shown there. The dns I use for ssh is also the "public ip", but if I execute "ifconfig" on the amazon server I get a different ip.
But with digital ocean I get the same problem, so it should not be amazon specific
the elastic ip is your public static ip, and it starts with 54, the one that starts with 172 or such, is a private ip for inside the amazon intranet

I have the same problem with masternode list showing my ip with port 0. My home router has port 9999 open to my local machine hosting my masternode with funds. My EC2 has port 9999 open to the world.

darkcoind getinfo doesn't tell me anything about any ports. Does it show port info to you all?
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
Ok, so the answer to getting it right is to use this: ./darkcoind -masternodeaddr=54.xxx.xxx.xxx:9999 to start your wallet.

Unfortunately, I have been unable to get one of my "54.xxx.xxx.xxx:0" : 1 off the Masternode list and I think that's causing my proper version not to take. Because when I stop my local darkcoind wallet to put it in storage, it disappears of the masternode list (though it's there when my local darkcoind wallet is running) Can anyone think of a way for me to get the incorrect version off the masternode list?

On my other node, it disappeared when I stopped the wallet, and the new one, with the proper port stayed on the list even after I turned my local darkcoind wallet off.

Any help is greatly appreciated, thanks!!!
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
stuff

edit: one more info, i transfered the 1000 DRK to a windows wallet, than copied that wallet to the linux server. So i got a non-encrypted original windows wallet on the local linux server. Could that be a problem?
never save unencrypted wallets anywhere.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
So does anyone know how I might get my Masternode off the list? Both my local wallet with the funds and my remote wallet on a server are turned off, the machines have been restarted, and yet my masternode ip (with 0 instead of 9999) is on the masternode list (from 3rd computer) I can't get rid of it, and I suspect until I get rid of it, I can't properly start my masternode (with port 9999)

I wish there was a way to clear it off the list, grrr!