• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

Corrupt dashman installer???


Hello all,

I have a couple masternodes that I operate. A few months back I transitioned to using dashman to update them. most of them have worked great. I have had troubles with one though. It entered pose ban status and I did not do enough research to figure out how to fix it so I reinstalled my Linux server and started completely over to create a new massternode. I resent the 1000 got new bls keys and followed the setup process start to finish. Once complete the node shows up on the list and was receiving payments. However it never quite seamed to fully function. I was unable to get dashcentral to ever work with this last MN even though my other do just fine. The strange thing is when I try
~/dashman/dashman status

this is the result:
/home/********/dashman/dashman: line 11: die: command not found
dashman version 0.1.28 (7-gd706581-dirty) - Fri 08 May 2020 01:22:07 PM UTC
gathering info, please wait... /home/********/dashman/lib/dashman_functions.sh: line 960: netstat: command not found
/home/*********/dashman/lib/dashman_functions.sh: line 961: netstat: command not found
hostname : guest
host uptime/load average : 0 days, 0.15 0.06 0.06
dashd bind ip address : ***.**.***.***
dashd version :
dashd up-to-date : YES
dashd running : YES
dashd uptime : 0 days, 0 hours, 17 mins, 21 secs
dashd responding (rpc) : YES
dashd listening (ip) : NO
dashd connecting (peers) : NO
dashd port open : YES
dashd connection count : 0
dashd blocks synced : YES
last block (local dashd) : 1267405
(chainz) : 1267404
(dash.org) : 0
(dashwhale) : 1267405
(masternode.me) : 1267403 - no forks detected
dashd current difficulty : 278004246.7901338
masternode count : 4590

I have double checked my dash.conf file and I do have listen set to 1 and max connections set to 64 and add node

In this state I receive payment and no PoSe ban score.

The problem is I can not get
opt/dashcentral-updater/dcupdater to function and if my MN has a problem i do not get notified and also no auto restart. this is what I see when I run that command :

Can't load '/tmp/par-**myusermane**/cache-9ae2ed082d463ce18e50bbceb5b5580dcfd43a70/7a23417c.so' for module Crypt::SSLeay: libssl.so.1.0.0: cannot open shared object file: No such file or directory at /usr/lib/perl/5.14/DynaLoader.pm line 184.
at /usr/share/perl5/PAR/Heavy.pm line 75
Compilation failed in require at Net/SSL.pm line 19.
Compilation failed in require at script/dcupdater.pl line 14.
BEGIN failed--compilation aborted at script/dcupdater.pl line 14.

Last week I was busy and my MN went down and it became PoSe banned again. So I thought perhaps there was a problem with the install so I wiped the server and reinstalled Linux and my MN again.

Still getting the same results using dashman to install MN.

Any suggestions would be appreciated. As I've said it is running and appears to be ok but something is not right.
Please do not use Dashman anymore as the creator of it is MIA and not around the project anymore.
I will remove the dashman instructions when the docs are forked for the upcoming version 0.16 release. I have been working on an alternative tool which is theoretically ready to support mainnet masternodes, but would appreciate more testing on testnet (or evonet) first. Apologies for not posting this on the forum earlier, small announcement and demo video is here.

Until this is ready, the manual install docs are still supported, and @xkcd has an excellent guide for installing masternodes as well.